Several newb questions (state, bind, win on macOS)

App no longer crashes if I comment a line in Component.hx

        if (dispose == true) {
            child._isDisposed = true;

so I assume one child is the culprit, but whatever I did, it’s when I add any more component that it crashes.
It drives me insane!

EDIT : replaced with


same crash

So I rebuilded my project with -debug and the crash is different

Unhandled unknown exception; terminating the application.
Abort trap: 6

I still don’t see why…
I tried to load the Component that crash on startup

      app.ready(function() {
            app.addComponent( new CrashingView() );

no problem!!!

So it comes from what happen BEFORE I load it

Can you attache a test app?

EDIT: ah, bugs 2 & 8 correct?


unfortunately no.
I’m unable to create a test app, while, trust me, I tried!
It only crashes on my case, so I’ll try to anonymize (NDA product so :hot_face:) part of my app which crashes

EDIT : so I did it…it crashes on my app, it doesn’t on my bugssample app :hot_face:

I made it!!!
I made it crashes::
It’s the first time in ages I’m happy to (re)produce a crash!

What is VERY strange is the crash occurs only if my component is the first added to the HaxeUIApp.
Please look for comment added on Main.hx (bug10)

1 Like

Great! Thanks, ill be looking at these issues “soon” (other things keep coming up)… but thanks for the repro!


I really hope you’ll be able to fix (the error or my stupidity)
This one locks my current project :frowning:

I really cant seem to follow what #10 is trying to do… I there any chance you could try and put the issue into a totally separate project - it seems to have components over components (wxWidgets doesnt like overlapping components) and seems to do some other things that im just not understanding - or even understanding what you are trying to do :slight_smile:


PS: you might want to join the #haxe discourse too ( - will be easier to chat there - up to you though of course. :slight_smile:

are you trying to do something like this:


yes, it seems you got it.

I want change current view by a new one, not using tabs
intro -> create -> edit -> end -> intro

But you added a theContainer, why is it needed ? it’s a view in a box into a vbox…?

EDIT : to be sure, I did the same and…crashes :frowning: . so adding another layer didn’t fix it

Does the sample i attached crash also? Can you try and make that sample crash in the same manner? (with minimal code).

The reason i used theContainer is because that is a child of the main view, so i can add buttons and other controls in the main view.

Thanks again!

The sample doesn’t crash : not enough component on screen…
The sample updated , which crash, is available here

remove some components on second.xml (42 in my case) and it will no longer crash :exploding_head:

can you pull latest and try again, i fix a few issues that i think might have fixed it (i cant reproduce the crash anymore)

I confirm it seems to be fixed.
I updated my sample app with “Fixed” state

Bad news : it still crashes but only when a listView is on screen

hmmmm… any chance of another minimal sample please? This should all be fixed at this point (unless this is a different crash)

unfortunately no…
my haxeui-bugs apps crashes, but not my main app
I don’t understand why…I don’t even register event :frowning:
could it be from the datalist ?

Hmmm, this is super weird. And all this was working pre haxe 4.1.1?

It was crashing with 4.0 also
Sorry, I forgot to retest it after your initial fix…
My main project was working, I didn’t think my haxui-bug app will break :frowning:

OK, this seems weird, if you do manage to isolate it would be useful.