Vscode does not show haxe.ui as a library :(

i installed haxeui-core and created a project thru “haxelib run haxeui-core create openfl”. when i compiled to hashlink there were no errors at all and it worked perfectly fine. but when i try coding in vscode, the autocomplete does not work for haxeui and it shows an error saying that “haxe.ui” is not a type found. is this maybe a plugin issue? i installed the lime plugin and the haxe plugin already btw. please help me T_T

Hi! Welcome!

So, sometimes the language server seems to mess up with haxeui, what version of haxe are you using? What version of haxeui?

Another thing that is possibly happening (quite likely) is that the haxeui “create” creates and application.xml, while this is perfectly fine for lime / openfl the lime plugin only recognizes project.xml, try renaming your file from application.xml to project.xml and restart vscode, see if that helps.


1 Like

it works now, i found out that by adding a build.hxml that has the haxeui library can decieve the editor into thinking i have haxeui installed. i had no issues since.

1 Like